Forgotten Password emails not getting sent

Discuss bugs related to Logic Invoice.
cmurphy060960
Posts: 54
Joined: Mon May 16, 2016 9:51 am

Forgotten Password emails not getting sent

Postby cmurphy060960 » Mon May 30, 2016 3:19 am

Hi Esmond,

Just went LIVE with LI this past week. Everything working nicely. :D

We had one customer who had trouble with their login credentials - with multiple previous customer account setup/login successes I'm assuming it was a user error. Just to make sure the PW reset (from the login screen) was working - I ran a test:

No email was generated - for admin or customer.

The success message reads only "You have successfully reset your password." (see screen shot)

thinking it should read ... "You have successfully reset your password. A temporary pW was sent to your email address." (I'm sure I can find this in the code and change it)

I checked (this time) to see if the "Forgotten Password" Admin & Customer emails were enabled and they are.

Forgotten PW.PNG
Forgotten PW.PNG (10.72 KiB) Viewed 1410 times


Thanks
Chris

User avatar
Esmond
Site Admin
Posts: 241
Joined: Tue Sep 15, 2015 3:08 pm
Location: Singapore
Contact:

Re: Forgotten Password emails not getting sent

Postby Esmond » Mon May 30, 2016 7:41 am

is the email entered correctly and there's an email template setup too? It should work alright for password reset email.

cmurphy060960
Posts: 54
Joined: Mon May 16, 2016 9:51 am

Re: Forgotten Password emails not getting sent

Postby cmurphy060960 » Mon May 30, 2016 8:47 am

Everything appears setup correctly.
Forgotten PW2.PNG
Forgotten PW2.PNG (8.31 KiB) Viewed 1404 times

If I change "test" user PW through admin panel I get both admin and customer email notification re: "Account Updated"

Even if the users email is entered incorrectly (in which case the user gets an alert that the email address doesn't exist) At any rate as admin I should still get a notification.

If I log in as "test" user and change PW through the users account page, no emails are sent - not sure if this is expected.

So emails are going out for all other notifications - just not "Forgot Password"
So doesn't seem like a server issue.

As a side note - I looked at the System > Email set up page... I'm using Mail (instead of SMTP) I did not enter the Mail Parameter initially - as mail was being sent - as a test I put in my email company address, but didn't correct the issue. As a matter of fact with the email parameter entered - admin stopped getting notifications when user PW is updated by admin.

I'm also testing this on a clean install - in case it was something I created.

Would it be helpful to give you user/customer access to this install for testing purposes?

I may be missing the obvious here :?

cmurphy060960
Posts: 54
Joined: Mon May 16, 2016 9:51 am

Re: Forgotten Password emails not getting sent

Postby cmurphy060960 » Mon May 30, 2016 6:33 pm

Note: I did a PW reset from admin login page and received a PW reset email.

User avatar
Esmond
Site Admin
Posts: 241
Joined: Tue Sep 15, 2015 3:08 pm
Location: Singapore
Contact:

Re: Forgotten Password emails not getting sent

Postby Esmond » Mon May 30, 2016 8:34 pm

Could you possibly drop me a PM with your admin login details and FTP login details? I can have a look at the issue for you

cmurphy060960
Posts: 54
Joined: Mon May 16, 2016 9:51 am

Re: Forgotten Password emails not getting sent

Postby cmurphy060960 » Mon May 30, 2016 9:14 pm

Getting this when I try to send PM

Some users couldn’t be added as they have disabled private message receipt.

User avatar
Esmond
Site Admin
Posts: 241
Joined: Tue Sep 15, 2015 3:08 pm
Location: Singapore
Contact:

Re: Forgotten Password emails not getting sent

Postby Esmond » Tue May 31, 2016 8:07 am

Sorry about that, had PM disabled. Please try again.


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest